Autodesk.Revit.DB.Macros Namespace


Autodesk. Revit. DB. Macros Namespace

Classes
Class Description
Public class AddInIdAttribute The custom AddInId attribute for Macros macros use only.
Public class ApplicationEntryPoint For Revit Macros use only.
Public class Macro An individual Autodesk Revit Macro which can be executed.
Public class MacroManager Manager object for the Macro modules of the application.
Public class MacroManagerIterator An iterator to a MacroManager.
Public class MacroModule A container for individual macros. As it relates to the macros editor, one MacroModule represents a project that can be loaded and edited from within the editor.
Public class MacroModuleIterator An iterator to the Macros in a MacroModule.
Public class ModuleSettings The module settings.
Public class VendorIdAttribute The custom VendorId attribute for Macros macros use only.
Interfaces
Interface Description
Public interface IEntryPoint The interface supporting Document and Application level entry point classes for macros.
Public interface IModuleMaker The interface used to create module project.
Enumerations
Enumeration Description
Public enumeration ApplicationMacroOptions The application macro options.
Public enumeration MacroEnvironment The Macro environments.
Public enumeration MacroLanguageType The Macro language types.
Public enumeration ModuleStatus The Macro module status.