Element |
A filter used to find elements whose category matches any of a given set of categories.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementMulticategoryFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementMulticategoryFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementMulticategoryFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementMulticategoryFilter(ICollection BuiltInCategory ) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection ElementId ) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection BuiltInCategory , Boolean) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection ElementId , Boolean) | Initializes a new instance of the ElementMulticategoryFilter class |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetCategoryIds | Gets the category ids assigned to this filter. |

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.