Element |
A filter used to find elements whose category matches any of a given set of categories.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementMulticategoryFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementMulticategoryFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementMulticategoryFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementMulticategoryFilter(ICollection BuiltInCategory ) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection ElementId ) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection BuiltInCategory , Boolean) | Initializes a new instance of the ElementMulticategoryFilter class |
![]() | ElementMulticategoryFilter(ICollection ElementId , Boolean) | Initializes a new instance of the ElementMulticategoryFilter class |

Name | Description | |
---|---|---|
![]() | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCategoryIds | Gets the category ids assigned to this filter. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.