ElementMulticategoryFilter Class


Element Multicategory Filter Class

A filter used to find elements whose category matches any of a given set of categories.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementMulticategoryFilter : ElementQuickFilter

The ElementMulticategoryFilter type exposes the following members.

Constructors
Name Description
Public method ElementMulticategoryFilter(ICollection BuiltInCategory ) Constructs a new instance of a filter to match elements by built-in category.
Public method ElementMulticategoryFilter(ICollection ElementId ) Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method ElementMulticategoryFilter(ICollection BuiltInCategory , Boolean) Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method ElementMulticategoryFilter(ICollection ElementId , Boolean) Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.
Top
Properties
Name Description
Top
Methods
Name Description
Public method GetCategoryIds Gets the category ids assigned to this filter.
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also