ExportPatternKey Class


Export Pattern Key Class

A key used to represent an item stored in an ExportPatternTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportPatternKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportPatternKey : IDisposable

The ExportPatternKey type exposes the following members.

Constructors
Name Description
Public method ExportPatternKey Constructs a new default ExportPatternKey.
Public method ExportPatternKey(ExportPatternKey) Constructs a new copy of the input ExportPatternKey object.
Public method ExportPatternKey(FillPatternTarget, String) Constructs a new ExportPatternKey using the original fill pattern type and name as input.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OriginalFillPatternName The original FillPattern name.
Public property OriginalFillPatternType The original FillPattern type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportPatternKey
Top
See Also