Export |
A key used to represent an item stored in an ExportPatternTable .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExportPatternKey type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportPatternKey | Constructs a new default ExportPatternKey. |
![]() | ExportPatternKey(ExportPatternKey) | Constructs a new copy of the input ExportPatternKey object. |
![]() | ExportPatternKey(FillPatternTarget, String) | Constructs a new ExportPatternKey using the original fill pattern type and name as input. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OriginalFillPatternName | The original FillPattern name. |
![]() | OriginalFillPatternType | The original FillPattern type. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExportPatternKey |