ExportIFCCategoryKey Class


Export IFCCategory Key Class

Represents a Revit category item stored in a template.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportIFCCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportIFCCategoryKey : IDisposable

The ExportIFCCategoryKey type exposes the following members.

Constructors
Name Description
Public method ExportIFCCategoryKey Constructs a new ExportIFCCategoryKey with default values.
Public method ExportIFCCategoryKey(String, String, CustomSubCategoryId) Constructs a new ExportIFCCategoryKey with category, subcategory names and special id.
Top
Properties
Name Description
Public property CategoryName The Revit category name.
Public property CustomSubCategoryId The Revit custom subcategory id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SubCategoryName The Revit subcategrory name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportIFCCategoryKey
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also