Export |
Represents a Revit category item stored in a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExportIFCCategoryKey type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportIFCCategoryKey | Constructs a new ExportIFCCategoryKey with default values. |
![]() | ExportIFCCategoryKey(String, String, CustomSubCategoryId) | Constructs a new ExportIFCCategoryKey with category, subcategory names and special id. |

Name | Description | |
---|---|---|
![]() | CategoryName | The Revit category name. |
![]() | CustomSubCategoryId | The Revit custom subcategory id. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SubCategoryName | The Revit subcategrory name. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExportIFCCategoryKey |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |