Definition Class


Definition Class

The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class Definition

The Definition type exposes the following members.

Properties
Name Description
Public property Name The user visible name for the parameter.
Top
Methods
Name Description
Public method Code example GetDataType Gets a ForgeTypeId identifying the data type describing values of the parameter.
Public method GetGroupTypeId Returns the identifier of the parameter definition's parameter group.
Top
Remarks
This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilize this Definition base class as then the code will be applicable to both internal and external parameter definitions.
See Also