ViewFamily Enumeration


View Family Enumeration

An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ViewFamily
Members
Member name Value Description
AreaPlan 110 Area plan view.
CeilingPlan 111 Ceiling plan view.
CostReport 106 Cost report view (obsolete).
Detail 113 Detail view.
Drafting 108 Drafting view.
Elevation 114 Elevation view.
FloorPlan 109 Floor plan view.
GraphicalColumnSchedule 119 Graphical column schedule.
ImageView 104 Rendering view.
Invalid 101 Invalid view type.
Legend 117 Legend view.
LoadsReport 115 HVAC load report.
PanelSchedule 118 Panel schedule.
PressureLossReport 116 Pressure loss report.
Schedule 105 Schedule view.
Section 112 Section view.
Sheet 107 Sheet view.
StructuralPlan 120 Structural plan view.
SystemsAnalysisReport 121 Systems analysis report.
ThreeDimensional 102 3D view.
Walkthrough 103 Walkthrough view.
See Also