ViewFamily Enumeration


View Family Enumeration

An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ViewFamily
Members
Member name Value Description
Invalid 101 Invalid view type.
ThreeDimensional 102 3D view.
Walkthrough 103 Walkthrough view.
ImageView 104 Rendering view.
Schedule 105 Schedule view.
CostReport 106 Cost report view (obsolete).
Sheet 107 Sheet view.
Drafting 108 Drafting view.
FloorPlan 109 Floor plan view.
AreaPlan 110 Area plan view.
CeilingPlan 111 Ceiling plan view.
Section 112 Section view.
Detail 113 Detail view.
Elevation 114 Elevation view.
LoadsReport 115 HVAC load report.
PressureLossReport 116 Pressure loss report.
Legend 117 Legend view.
PanelSchedule 118 Panel schedule.
GraphicalColumnSchedule 119 Graphical column schedule.
StructuralPlan 120 Structural plan view.
SystemsAnalysisReport 121 Systems analysis report.
See Also