Paint Method (ElementId, Face, ElementId)


Document Paint(Element Id, Face, Element Id) Method

Paint the element's face with specified material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void Paint(
	ElementId elementId,
	Face face,
	ElementId materialId
)

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.
materialId ElementId
The material to be painted on the face
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document -or- The element materialId does not exist in the document -or- The face doesn't belong to the element -or- The materialId doesn't specify a material element. -or- The element's face cannot be painted.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also