BRepBuilder Class


BRep Builder Class

A class that allows direct construction of geometry objects (solids, open shells, etc.).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB BRepBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BRepBuilder : ShapeBuilder

The BRepBuilder type exposes the following members.

Constructors
Name Description
Public method BRepBuilder Construct a BRepBuilder to use in constructing geometry.
Top
Properties
Name Description
Top
Methods
Name Description
Public method AddCoEdge Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in the loop (i.e., in their topological order).
Public method AddEdge Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.
Public method AddFace Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Public method AddLoop Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.
Public method AllowRemovalOfProblematicFaces Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.
Public method CanAddGeometry A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.
Public method Finish Complete construction of the geometry. The geometry will be validated and, if valid, stored in this BRepBuilder. Otherwise it will be deleted.
Public method FinishFace Indicates that the caller has finished defining the given face.
Public method FinishLoop Indicates that the caller has finished defining the given loop.
Public method GetResult Get the Solid built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method GetResult(ExternalGeometryId, BRepBuilderPersistentIds) Get the ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method Static member IsPermittedSurfaceType A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Public method IsResultAvailable A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object has successfully built a b-rep.
Public method IsValidEdgeId A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.
Public method IsValidFaceId A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.
Public method IsValidLoopId A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.
Public method IsValidPersistentIdsMap A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.
Public method RemovedSomeFaces Returns 'true' if BRepBuilder removed some problematic faces from the output geometry, 'false' if not. If allowRemovalOfProblematicFaces was not called to enable removal of problematic faces, this function will return 'false'. Note that if some faces were removed, the output geometry's type will be OpenShell regardless of the expected type that was specified when the BRepBuilder was created.
Public method SetAllowShortEdges Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.
Public method SetFaceMaterialId Sets material id to a face.
Top
See Also