Cylindrical |
A cylindrical surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CylindricalSurface type exposes the following members.

Name | Description | |
---|---|---|
![]() | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder. |
![]() | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder. |
![]() | Radius | Radius of the circle that defines the base of this cylinder. |
![]() | XDir | X axis of the local coordinate system associated with this cylinder. |
![]() | YDir | Y axis of the local coordinate system associated with this cylinder. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Construct a cylindrical surface defined by a local coordinate system and a radius. |
![]() | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface. |

The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.