Cylindrical |
A cylindrical surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CylindricalSurface type exposes the following members.

Name | Description | |
---|---|---|
![]() | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface ) |
![]() | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface ) |
![]() | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder. |
![]() | Radius | Radius of the circle that defines the base of this cylinder. |
![]() | XDir | X axis of the local coordinate system associated with this cylinder. |
![]() | YDir | Y axis of the local coordinate system associated with this cylinder. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Construct a cylindrical surface defined by a local coordinate system and a radius. |
![]() | Dispose | (Inherited from Surface ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface ) |
![]() | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.