CylindricalSurface Class


Cylindrical Surface Class

A cylindrical surface.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Surface
Autodesk.Revit.DB CylindricalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CylindricalSurface : Surface

The CylindricalSurface type exposes the following members.

Properties
Name Description
Public property Axis Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Surface )
Public property OrientationMatchesParametricOrientation Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
(Inherited from Surface )
Public property Origin Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property Radius Radius of the circle that defines the base of this cylinder.
Public property XDir X axis of the local coordinate system associated with this cylinder.
Public property YDir Y axis of the local coordinate system associated with this cylinder.
Top
Methods
Name Description
Public method Static member Create Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method Dispose
(Inherited from Surface )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBoundingBoxUV Gets the UV bounding box of the surface.
(Inherited from Surface )
Public method GetFrameOfReference Returns frame of reference associated with this CylindricalSurface.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Project Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
(Inherited from Surface )
Public method ProjectWithGuessPoint Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
(Inherited from Surface )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.
See Also