CylindricalSurface Class


Cylindrical Surface Class

A cylindrical surface.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Surface
Autodesk.Revit.DB CylindricalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CylindricalSurface : Surface

The CylindricalSurface type exposes the following members.

Properties
Name Description
Public property Axis Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property Origin Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property Radius Radius of the circle that defines the base of this cylinder.
Public property XDir X axis of the local coordinate system associated with this cylinder.
Public property YDir Y axis of the local coordinate system associated with this cylinder.
Top
Methods
Name Description
Public method Static member Create Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method GetFrameOfReference Returns frame of reference associated with this CylindricalSurface.
Top
Remarks
The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.
See Also