RebarTrimExtendData Class


Rebar Trim Extend Data Class

The class that contains the information needed to calculate and return the curves in a trimmed/extended state, and also find the constraints that trim/extend it.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarTrimExtendData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarTrimExtendData : IDisposable

The RebarTrimExtendData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddBarGeometry(CurveLoop) Adds a new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Public method AddBarGeometry(IList Curve )
Public method CanAddBarGeometry Returns true if getNumberOfBarGeometry() is less than GetNumberOfBars(), false otherwise.
Public method ClearAllAddedBarGeometry This function will remove all bars geometry that were added by calling AddBarGeometry().
Public method CreateEndConstraint
Public method CreateStartConstraint
Public method Dispose Releases all resources used by the RebarTrimExtendData
Public method GetAddedBarGeometry Gets the added curves that will represent the bar at index barIndex.
Public method GetNumberOfBarGeometry Gets the number of Bar Geometry that were added.
Public method GetRebarUpdateCurvesData Gets a class that contains information used as input and output for rebar free form calculation.
Top
Remarks
If new curves will be added by calling addBarGeometry(), the existing curves in Rebar element will be replaced with these curves. It will not add curves to the existing ones.
See Also