Rebar |
The class that contains the information needed to calculate and return the curves in a trimmed/extended state, and also find the constraints that trim/extend it.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarTrimExtendData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | AddBarGeometry(CurveLoop) | Adds a new rebar geometry. This information is set to the rebar after the API execution is finished successfully. |
![]() | AddBarGeometry(IList Curve ) | Adds a new rebar geometry. This information is set to the rebar after the API execution is finished successfully. |
![]() | CanAddBarGeometry | Returns true if getNumberOfBarGeometry() is less than GetNumberOfBars(), false otherwise. |
![]() | ClearAllAddedBarGeometry | This function will remove all bars geometry that were added by calling AddBarGeometry(). |
![]() | CreateEndConstraint | Creates a constraint for the end handle of the rebar. This constraint will be set preferred after the API execution is finished successfully. |
![]() | CreateStartConstraint | Creates a constraint for the start handle of the rebar. This constraint will be set preferred after the API execution is finished successfully. |
![]() | Dispose | Releases all resources used by the RebarTrimExtendData |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAddedBarGeometry | Gets the added curves that will represent the bar at index barIndex. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetNumberOfBarGeometry | Gets the number of Bar Geometry that were added. |
![]() | GetRebarUpdateCurvesData | Gets a class that contains information used as input and output for rebar free form calculation. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

If new curves will be added by calling addBarGeometry(), the existing curves in Rebar element will be replaced with these curves. It will not add curves to the existing ones.