Site |
Represents a proxy class exposing the interfaces needed to access details of a subregion.

System Object
Autodesk.Revit.DB.Architecture SiteSubRegion
Autodesk.Revit.DB.Architecture SiteSubRegion
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The SiteSubRegion type exposes the following members.

Name | Description | |
---|---|---|
![]() | HostId | The element id of the topography surface hosting this SiteSubRegion. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | TopographySurface | The TopographySurface element which this SiteSubRegion represents. |

Name | Description | |
---|---|---|
![]() ![]() | Create(Document, IList CurveLoop ) | Obsolete. |
![]() ![]() | Create(Document, IList CurveLoop , ElementId) | Obsolete. |
![]() | Dispose | Releases all resources used by the SiteSubRegion |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundary | Gets the boundary of current subregion. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidBoundary | |
![]() | SetBoundary | Obsolete. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

In the Revit database, both TopographySurface elements and subregion elements are represented by the same TopographySurface element subclass. In the Revit API, this SiteSubRegion class exists to separate the interfaces for subregions from those of topography surfaces.