SiteSubRegion Class


Site Sub Region Class

Represents a proxy class exposing the interfaces needed to access details of a subregion.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture SiteSubRegion

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SiteSubRegion : IDisposable

The SiteSubRegion type exposes the following members.

Properties
Name Description
Public property HostId The element id of the topography surface hosting this SiteSubRegion.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TopographySurface The TopographySurface element which this SiteSubRegion represents.
Top
Methods
Name Description
Public method Static member Create(Document, IList CurveLoop ) Obsolete.
Creates a new SiteSubRegion element and adds it to the document.
Public method Static member Create(Document, IList CurveLoop , ElementId) Obsolete.
Creates a new SiteSubRegion element with assigned TopographySurface to be hosted and adds it to the document.
Public method Dispose Releases all resources used by the SiteSubRegion
Public method GetBoundary Gets the boundary of current subregion.
Public method Static member IsValidBoundary Identifies whether the given curve loops compose a valid boundary.
Public method SetBoundary Obsolete.
Set the given curve loops as the boundary of an existing SiteSubRegion.
Top
Remarks
In the Revit database, both TopographySurface elements and subregion elements are represented by the same TopographySurface element subclass. In the Revit API, this SiteSubRegion class exists to separate the interfaces for subregions from those of topography surfaces.
See Also