Settings Class


Settings Class

The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Settings : APIObject

The Settings type exposes the following members.

Properties
Name Description
Public property Categories Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property ElectricalSetting Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property TilePatterns Retrieves an object that provides access to the TilePattern objects in the document.
Top
Methods
Name Description
Top
See Also