Settings Class


Settings Class

The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Settings : APIObject

The Settings type exposes the following members.

Properties
Name Description
Public property Categories Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property ElectricalSetting Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property TilePatterns Retrieves an object that provides access to the TilePattern objects in the document.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also