Settings Class |
The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Settings type exposes the following members.

Name | Description | |
---|---|---|
![]() | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project. |
![]() | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project. |
![]() | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document. |

Name | Description | |
---|---|---|