Print |
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PrintSetup type exposes the following members.

Name | Description | |
---|---|---|
![]() | CurrentPrintSetting | The current Print Setting of Print Setup. |
![]() | InSession | The in-session Print Setting of Print Setup. |

Name | Description | |
---|---|---|
![]() | Delete | Delete the current print setting, and make the In-Session setting as the current one. |
![]() | Rename | Rename the current print setting with the specified name. |
![]() | Revert | Revert the current print setting. |
![]() | Save | Save the changes for the current print setting. |
![]() | SaveAs | Save the current print setting to another print setting with the specified name. |

The Print Setup object can only get from PrintManager object.