Print |
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PrintSetup type exposes the following members.

Name | Description | |
---|---|---|
![]() | CurrentPrintSetting | The current Print Setting of Print Setup. |
![]() | InSession | The in-session Print Setting of Print Setup. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Delete | Delete the current print setting, and make the In-Session setting as the current one. |
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Rename | Rename the current print setting with the specified name. |
![]() | Revert | Revert the current print setting. |
![]() | Save | Save the changes for the current print setting. |
![]() | SaveAs | Save the current print setting to another print setting with the specified name. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The Print Setup object can only get from PrintManager object.