PrintSetup Class


Print Setup Class

Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrintSetup : APIObject

The PrintSetup type exposes the following members.

Properties
Name Description
Public property CurrentPrintSetting The current Print Setting of Print Setup.
Public property InSession The in-session Print Setting of Print Setup.
Top
Methods
Name Description
Public method Delete Delete the current print setting, and make the In-Session setting as the current one.
Public method Rename Rename the current print setting with the specified name.
Public method Revert Revert the current print setting.
Public method Save Save the changes for the current print setting.
Public method SaveAs Save the current print setting to another print setting with the specified name.
Top
Remarks
The Print Setup object can only get from PrintManager object.
See Also