PrintSetup Class


Print Setup Class

Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrintSetup : APIObject

The PrintSetup type exposes the following members.

Properties
Name Description
Public property CurrentPrintSetting The current Print Setting of Print Setup.
Public property InSession The in-session Print Setting of Print Setup.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Top
Methods
Name Description
Public method Delete Delete the current print setting, and make the In-Session setting as the current one.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Rename Rename the current print setting with the specified name.
Public method Revert Revert the current print setting.
Public method Save Save the changes for the current print setting.
Public method SaveAs Save the current print setting to another print setting with the specified name.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The Print Setup object can only get from PrintManager object.
See Also