TessellatedShapeBuilder Class


Tessellated Shape Builder Class

A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB TessellatedShapeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TessellatedShapeBuilder : ShapeBuilder

The TessellatedShapeBuilder type exposes the following members.

Constructors
Name Description
Public method TessellatedShapeBuilder Constructs a new instance of a TessellatedShapeBuilder.
Top
Properties
Name Description
Public property Fallback Defines acceptable fallback if the desired type of geometry can't be built.
Public property GraphicsStyleId Optional - if set, the built geometry will use that graphics style.
Public property IsFaceSetOpen Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property LogInteger Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property LogString String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property NumberOfCompletedFaceSets Number of completed face sets.
Public property OwnerInfo String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property Target Requests the type of geometry to be built.
Top
Methods
Name Description
Public method AddFace Adds a face to the currently open connected face set.
Public method AreTargetAndFallbackCompatible Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method Build Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method CancelConnectedFaceSet Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method Clear Erases all face set and clears the logs, if any.
Public method CloseConnectedFaceSet Closes the currently open connected face set.
Public method Static member CreateMeshByExtrusion
Public method DoesFaceHaveEnoughLoopsAndVertices Checks whether 'face' has enough loops and vertcies to be valid.
Public method GetBuildResult Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method OpenConnectedFaceSet Opens a new connected face set.
Top
Remarks
Creates a geometry populated with faces defined by TessellatedFace objects stored in the input connected face sets. The faces defined by each connected face set may form an open shell or the boundary of a solid 3D region. All faces are planar and have polyline boundaries, defined as sequences of 3d coordinates. Faces are added to the builder as a part of connected face sets, representing faces which share edges. Order of faces in the sets is irrelevant. Faces can only be added to the builder when a face set has been opened and is available to take in faces (use OpenConnectedFaceSet(Boolean) to open a new face set). Before attempting to build Revit geometry from the builder the current face set should be closed ( CloseConnectedFaceSet ). The builder allows for the possibility of multiple face sets. The builder will try to create a geometry valid in Revit despite inconsistencies or omissions in the input data.
  • For each connected face set, it will check the face orientations and change them wherever needed so that the orientations of the faces in that set are consistent.
  • If a connected face set is closed, it will check if the face normals point outward. If not, it will reverse the orientations of all faces. That means, each closed connected face set will represent a solid.
Limitations in the current implementation:
  • It does not support the definition of a "void", even if the user had set the orientations of the faces to define a "void".
  • If there is more than one connected face set, it does not check if they intersect or overlap each other.
See Also