CustomFieldData Class


Custom Field Data Class

A class that offer access to the information about a custom field.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CustomFieldData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CustomFieldData : IDisposable

The CustomFieldData type exposes the following members.

Properties
Name Description
Public property DefaultRowHeightOnSheet Identifies the default row height for this field.
Public property FieldName The name of this custom field.
Public property FieldTooltip The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CustomFieldData
Public method GetCustomFieldId Gets an unique identifier of the custom field.
Public method GetCustomFieldProperties Gets an instance of ICustomFieldProperties which represents the properties of this field.
Public method SetCustomFieldProperties Sets an instance of ICustomFieldProperties which represents the properties of this field.
Public method ValidateCustomFieldProperties Validates the custom field properties.
Top
See Also