Custom |
A class that offer access to the information about a custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CustomFieldData type exposes the following members.

Name | Description | |
---|---|---|
![]() | DefaultRowHeightOnSheet | Identifies the default row height for this field. |
![]() | FieldName | The name of this custom field. |
![]() | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the CustomFieldData |
![]() | GetCustomFieldId | Gets an unique identifier of the custom field. |
![]() | GetCustomFieldProperties | Gets an instance of ICustomFieldProperties which represents the properties of this field. |
![]() | SetCustomFieldProperties | Sets an instance of ICustomFieldProperties which represents the properties of this field. |
![]() | ValidateCustomFieldProperties | Validates the custom field properties. |