Part |
General Part utility methods

System Object
Autodesk.Revit.DB PartUtils
Autodesk.Revit.DB PartUtils
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The PartUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | AreElementsValidForCreateParts | |
![]() ![]() | ArePartsValidForDivide | |
![]() ![]() | ArePartsValidForMerge | |
![]() ![]() | CreateMergedPart | |
![]() ![]() | CreateParts(Document, ICollection ElementId ) | |
![]() ![]() | CreateParts(Document, ICollection LinkElementId ) | |
![]() ![]() | DivideParts | |
![]() ![]() | FindMergeableClusters | |
![]() ![]() | GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element. |
![]() ![]() | GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element. |
![]() ![]() | GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element. |
![]() ![]() | GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element |
![]() ![]() | GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part. |
![]() ![]() | GetMergedParts | Retrieves the element ids of the source elements of a merged part. |
![]() ![]() | GetPartMakerMethodToDivideVolumeFW | Obtains the object allowing access to the divided volume properties of the PartMaker. |
![]() ![]() | GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part. |
![]() ![]() | GetSplittingCurves(Document, ElementId, Plane ) | Identifies the curves that were used to create the part and the plane in which they reside. |
![]() ![]() | GetSplittingElements | Identifies the elements ( reference planes, levels, grids ) that were used to create the part. |
![]() ![]() | HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts. |
![]() ![]() | HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts. |
![]() ![]() | IsMergedPart | Is the Part the result of a merge. |
![]() ![]() | IsPartDerivedFromLink | Is the Part derived from link geometry. |
![]() ![]() | IsValidForCreateParts | Identifies if the given element can be used to create parts. |