PartUtils Class


Part Utils Class

General Part utility methods
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PartUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class PartUtils

The PartUtils type exposes the following members.

Methods
Name Description
Public method Static member AreElementsValidForCreateParts
Public method Static member ArePartsValidForDivide
Public method Static member ArePartsValidForMerge
Public method Static member CreateMergedPart
Public method Static member CreateParts(Document, ICollection ElementId )
Public method Static member CreateParts(Document, ICollection LinkElementId )
Public method Static member DivideParts
Public method Static member FindMergeableClusters
Public method Static member GetAssociatedPartMaker(Document, ElementId) Gets associated PartMaker for an element.
Public method Static member GetAssociatedPartMaker(Document, LinkElementId) Gets associated PartMaker for an element.
Public method Static member GetAssociatedParts(Document, ElementId, Boolean, Boolean) Returns all Parts that are associated with the given element.
Public method Static member GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) Returns all Parts that are associated with the given element
Public method Static member GetChainLengthToOriginal Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
Public method Static member GetMergedParts Retrieves the element ids of the source elements of a merged part.
Public method Static member GetPartMakerMethodToDivideVolumeFW Obtains the object allowing access to the divided volume properties of the PartMaker.
Public method Static member GetSplittingCurves(Document, ElementId) Identifies the curves that were used to create the part.
Public method Static member GetSplittingCurves(Document, ElementId, Plane ) Identifies the curves that were used to create the part and the plane in which they reside.
Public method Static member GetSplittingElements Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
Public method Static member HasAssociatedParts(Document, ElementId) Checks if an element has associated parts.
Public method Static member HasAssociatedParts(Document, LinkElementId) Checks if an element has associated parts.
Public method Static member IsMergedPart Is the Part the result of a merge.
Public method Static member IsPartDerivedFromLink Is the Part derived from link geometry.
Public method Static member IsValidForCreateParts Identifies if the given element can be used to create parts.
Top
See Also