BooleanOperationsUtils Class


Boolean Operations Utils Class

These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BooleanOperationsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BooleanOperationsUtils : IDisposable

The BooleanOperationsUtils type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member CutWithHalfSpace Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Public method Static member CutWithHalfSpaceModifyingOriginalSolid Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Public method Dispose Releases all resources used by the BooleanOperationsUtils
Public method Static member Code example ExecuteBooleanOperation Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
Public method Static member ExecuteBooleanOperationModifyingOriginalSolid Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Top
See Also