Boolean |
These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BooleanOperationsUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() ![]() | CutWithHalfSpace | Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points. |
![]() ![]() | CutWithHalfSpaceModifyingOriginalSolid | Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points. |
![]() | Dispose | Releases all resources used by the BooleanOperationsUtils |
![]() ![]() ![]() | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result. |
![]() ![]() | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result. |