GetReferences Method


Family Instance Get References Method

Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Reference> GetReferences(
	FamilyInstanceReferenceType referenceType
)

Parameters

referenceType FamilyInstanceReferenceType
The family reference type.

Return Value

IList Reference
Returns all the family instance references corresponding to reference planes and reference lines of the given reference type. Returns null if there are no family instance references of the given reference type, or if the input reference type is FamilyInstanceReferenceType.NotAReference.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
Reference planes from the instance's family that have their "Is Reference" property set to "Not a Reference" do not create references in the family instance.
See Also