Options Class |
User preferences for parsing of geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Options type exposes the following members.

Name | Description | |
---|---|---|
![]() | Options | Creates a default Options object. |
![]() | Options(Options) | Copy constructor. |

Name | Description | |
---|---|---|
![]() | ComputeReferences | Determines whether or not references to geometric objects are computed. |
![]() | DetailLevel | The detail level for the geometry extracted with these options. |
![]() | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false. |
![]() | View | The view used for geometry extraction. |

Name | Description | |
---|---|---|

This class determines the output of the Element.Geometry property.