Options Class


Options Class

User preferences for parsing of geometry.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Options : APIObject

The Options type exposes the following members.

Constructors
Name Description
Public method Options Creates a default Options object.
Public method Options(Options) Copy constructor.
Top
Properties
Name Description
Public property ComputeReferences Determines whether or not references to geometric objects are computed.
Public property DetailLevel The detail level for the geometry extracted with these options.
Public property IncludeNonVisibleObjects Whether to extract element geometry objects not set as Visible. The default is false.
Public property View The view used for geometry extraction.
Top
Methods
Name Description
Top
Remarks
This class determines the output of the Element.Geometry property.
See Also