Options Class


Options Class

User preferences for parsing of geometry.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Options : APIObject

The Options type exposes the following members.

Constructors
Name Description
Public method Options Creates a default Options object.
Public method Options(Options) Copy constructor.
Top
Properties
Name Description
Public property ComputeReferences Determines whether or not references to geometric objects are computed.
Public property DetailLevel The detail level for the geometry extracted with these options.
Public property IncludeNonVisibleObjects Whether to extract element geometry objects not set as Visible. The default is false.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property View The view used for geometry extraction.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This class determines the output of the Element.Geometry property.
See Also