Workset Class |
Represents a workset in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Workset type exposes the following members.

Name | Description | |
---|---|---|
![]() | Id | Id of the workset. (Inherited from WorksetPreview ) |
![]() | IsDefaultWorkset | Whether the workset is the default one. (Inherited from WorksetPreview ) |
![]() | IsEditable | Whether the workset is editable. |
![]() | IsOpen | Whether the workset is open (rather than closed). |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetPreview ) |
![]() | IsVisibleByDefault | Whether the workset is visible by default. |
![]() | Kind | Kind of the workset. |
![]() | Name | Name of the workset. (Inherited from WorksetPreview ) |
![]() | Owner | User name of the workset. (Inherited from WorksetPreview ) |
![]() | UniqueId | UniqueId of the workset. (Inherited from WorksetPreview ) |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a new workset. |
![]() | Dispose | (Inherited from WorksetPreview ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.