Workset Class |
Represents a workset in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Workset type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsEditable | Whether the workset is editable. |
![]() | IsOpen | Whether the workset is open (rather than closed). |
![]() | IsVisibleByDefault | Whether the workset is visible by default. |
![]() | Kind | Kind of the workset. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a new workset. |

Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.