Workset Class


Workset Class

Represents a workset in the document.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Workset : WorksetPreview

The Workset type exposes the following members.

Properties
Name Description
Public property IsEditable Whether the workset is editable.
Public property IsOpen Whether the workset is open (rather than closed).
Public property IsVisibleByDefault Whether the workset is visible by default.
Public property Kind Kind of the workset.
Top
Methods
Name Description
Public method Static member Code example Create Creates a new workset.
Top
Remarks
Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.
Example
public void GetWorksetsInfo(Document doc)
{
    String message = String.Empty;
    // Enumerating worksets in a document and getting basic information for each
    FilteredWorksetCollector collector = new FilteredWorksetCollector(doc);

    // find all user worksets
    collector.OfKind(WorksetKind.UserWorkset);

    // get information for each workset
    int count = 3;  // show info for 3 worksets only
    foreach (Workset workset in collector)
    {
        message += "Workset : " + workset.Name;
        message += "\nUnique Id : " + workset.UniqueId;
        message += "\nOwner : " + workset.Owner;
        message += "\nKind : " + workset.Kind;
        message += "\nIs default : " + workset.IsDefaultWorkset;
        message += "\nIs editable : " + workset.IsEditable;
        message += "\nIs open : " + workset.IsOpen;
        message += "\nIs visible by default : " + workset.IsVisibleByDefault;

        TaskDialog.Show("GetWorksetsInfo", message);

        if (0 == --count)
            break;
    }
}
See Also