GetRegionEnvelope Method


Compound Structure Get Region Envelope Method

Gets the envelope that a specified region spans.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxUV GetRegionEnvelope(
	int regionId
)

Parameters

regionId Int32
The id of the region.

Return Value

BoundingBoxUV
The envelope of the region.
Exceptions
Exception Condition
ArgumentException It is not a valid region id.
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().
See Also