Compound |
Gets the envelope that a specified region spans.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- regionId Int32
- The id of the region.
Return Value
BoundingBoxUVThe envelope of the region.

Exception | Condition |
---|---|
ArgumentException | It is not a valid region id. |
InvalidOperationException | This operation is valid only for vertically compound structures. |

This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().