GBXMLExportOptions Class


GBXMLExport Options Class

Green-Building XML Export options.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class GBXMLExportOptions : IDisposable

The GBXMLExportOptions type exposes the following members.

Constructors
Name Description
Public method GBXMLExportOptions Constructs a new instance of the options used to export a model in gbXML (green-building) format.
Public method GBXMLExportOptions(IList ElementId , IList ElementId ) Initializes a new instance of the GBXMLExportOptions class
Top
Properties
Name Description
Public property Encoding The encoding options to go into the processing instruction for the exported gbXML file.
Public property ExportAnalyticalSystems Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property ExportEnergyModelType The energy model type from which gbXML will be exported.
Public property IsConceptual Indicates if the exported gbXML is based on a conceptual energy analytical model from a conceptual mass model.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the GBXMLExportOptions
Public method GetMassIds Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method GetMassZoneIds Gets a list of mass zones to analyze in the exported gbXML.
Top
See Also