GBXMLExportOptions Class


GBXMLExport Options Class

Green Building XML Export options.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class GBXMLExportOptions : IDisposable

The GBXMLExportOptions type exposes the following members.

Constructors
Name Description
Public method GBXMLExportOptions Constructs a new instance of the options used to export a model in gbXML (Green Building XML) format.
Top
Properties
Name Description
Public property Encoding Obsolete.
The encoding options to go into the processing instruction for the exported gbXML file.
Public property ExportAnalyticalSystems Obsolete.
Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property ExportEnergyModelType Obsolete.
The energy model type from which gbXML will be exported.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the GBXMLExportOptions
Top
See Also