MultiServerService Class


Multi Server Service Class

This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class MultiServerService : ExternalService

The MultiServerService type exposes the following members.

Properties
Name Description
Public property ExecutionPolicy Specifies how a multi-server service executes servers during its execution.
Top
Methods
Name Description
Public method GetActiveServerIds Returns Ids of the currently active application-level servers registered for the service.
Public method GetActiveServerIds(Document) Returns Ids of the servers currently applicable to the given document for the service.
Public method SetActiveServers(IList Guid )
Public method SetActiveServers(IList Guid , Document)
Public method SetServerState This method will simply switch the active state of a server without affecting in any way the other servers.
Top
See Also