Multi |
This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.

System Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MultiServerService type exposes the following members.

Name | Description | |
---|---|---|
![]() | Description | The description for the service (Inherited from ExternalService ) |
![]() | ExecutionPolicy | Specifies how a multi-server service executes servers during its execution. |
![]() | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalService ) |
![]() | Name | The name of the service (Inherited from ExternalService ) |
![]() | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService ) |
![]() | ServiceId | The Id of the service (Inherited from ExternalService ) |
![]() | SupportActivation | Indicates if the service supports activation/deactivation of the servers. (Inherited from ExternalService ) |
![]() | VendorId | The vendor who provided the service (Inherited from ExternalService ) |

Name | Description | |
---|---|---|
![]() | AddServer | Registers a server with its service. (Inherited from ExternalService ) |
![]() | Dispose | (Inherited from ExternalService ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetActiveServerIds | Returns Ids of the currently active application-level servers registered for the service. |
![]() | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service. |
![]() | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetOptions | A copy of the options the service was registered with. (Inherited from ExternalService ) |
![]() | GetPublicAccessKey | Access key to use to execute a service. (Inherited from ExternalService ) |
![]() | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService ) |
![]() | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsRegisteredServerId | Checks if the Id represents a valid server that has been registered for the service. (Inherited from ExternalService ) |
![]() | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService ) |
![]() | SetActiveServers(IList Guid ) | Changes the active servers and/or their order. |
![]() | SetActiveServers(IList Guid , Document) | Changes the active servers and/or their order for the given document. |
![]() | SetServerState | This method will simply switch the active state of a server without affecting in any way the other servers. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |