Multi |
This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.

System Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService MultiServerService
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MultiServerService type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExecutionPolicy | Specifies how a multi-server service executes servers during its execution. |

Name | Description | |
---|---|---|
![]() | GetActiveServerIds | Returns Ids of the currently active application-level servers registered for the service. |
![]() | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service. |
![]() | SetActiveServers(IList Guid ) | Changes the active servers and/or their order. |
![]() | SetActiveServers(IList Guid , Document) | Changes the active servers and/or their order for the given document. |
![]() | SetServerState | This method will simply switch the active state of a server without affecting in any way the other servers. |