Wireframe |
Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The WireframeBuilder type exposes the following members.

Name | Description | |
---|---|---|
![]() | WireframeBuilder | Default constructor. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | AddCurve | Add a curve to the shape representation stored in this WireframeBuilder. |
![]() | AddPoint | Add a point to the shape representation stored in this WireframeBuilder. |
![]() | Reset | Clears the accumulated geometry. |
![]() ![]() | ValidateCurve | Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve(). |
![]() ![]() | ValidatePoint | Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input. |