WireframeBuilder Class


Wireframe Builder Class

Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB WireframeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireframeBuilder : ShapeBuilder

The WireframeBuilder type exposes the following members.

Constructors
Name Description
Public method WireframeBuilder Default constructor.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ShapeBuilder )
Top
Methods
Name Description
Public method AddCurve Add a curve to the shape representation stored in this WireframeBuilder.
Public method AddPoint Add a point to the shape representation stored in this WireframeBuilder.
Public method Dispose
(Inherited from ShapeBuilder )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Reset Clears the accumulated geometry.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method Static member ValidateCurve Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
Public method Static member ValidatePoint Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Top
See Also