WireframeBuilder Class


Wireframe Builder Class

Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB WireframeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireframeBuilder : ShapeBuilder

The WireframeBuilder type exposes the following members.

Constructors
Name Description
Public method WireframeBuilder Default constructor.
Top
Properties
Name Description
Top
Methods
Name Description
Public method AddCurve Add a curve to the shape representation stored in this WireframeBuilder.
Public method AddPoint Add a point to the shape representation stored in this WireframeBuilder.
Public method Reset Clears the accumulated geometry.
Public method Static member ValidateCurve Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
Public method Static member ValidatePoint Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Top
See Also