WorksharingSaveAsOptions Class


Worksharing Save As Options Class

This class contains options specific to worksharing SaveAs.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB WorksharingSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksharingSaveAsOptions : IDisposable

The WorksharingSaveAsOptions type exposes the following members.

Constructors
Name Description
Public method WorksharingSaveAsOptions Constructs a new WorksharingSaveAsOptions with default settings.
Top
Properties
Name Description
Public property ClearTransmitted For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OpenWorksetsDefault The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.
Public property SaveAsCentral Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the WorksharingSaveAsOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also