Worksharing |
This class contains options specific to worksharing SaveAs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The WorksharingSaveAsOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | WorksharingSaveAsOptions | Constructs a new WorksharingSaveAsOptions with default settings. |

Name | Description | |
---|---|---|
![]() | ClearTransmitted | For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OpenWorksetsDefault | The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify. |
![]() | SaveAsCentral | Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the WorksharingSaveAsOptions |