View |
Requests a new systems analysis in the background.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- options SystemsAnalysisOptions
- The additional options to run systems analysis. If empty, use the default value in the view element. The request may download the weather file at current site location if not specified in the options.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | No weather station is within 500 nautical miles of this site location. |
FileNotFoundException | Fail to download the weather file. |
InvalidOperationException | A valid energy model is required for systems analysis. -or- Unable to access the weather service. Try again later. |