RequestSystemsAnalysis Method


View Systems Analysis Report Request Systems Analysis Method

Requests a new systems analysis to be run in the background.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void RequestSystemsAnalysis(
	SystemsAnalysisOptions options
)

Parameters

options SystemsAnalysisOptions
The additional options to run systems analysis. If empty, use the default value in the view element. The request may download the weather file at current site location if not specified in the options.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException No weather station is within 500 nautical miles of this site location.
FileNotFoundException Fail to download the weather file.
InvalidOperationException A valid energy model is required for systems analysis. -or- Unable to export the gbxml file or access the weather service.
Remarks
Should be called from a transaction.
See Also