VertexStreamPosition Class


Vertex Stream Position Class

A stream that can be used to write vertices of type VertexPosition into a buffer (see VertexBuffer ).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class VertexStreamPosition : VertexStream

The VertexStreamPosition type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from VertexStream )
Top
Methods
Name Description
Public method AddVertex Inserts a VertexStreamPosition into the stream and associated buffer.
Public method AddVertices
Public method Dispose
(Inherited from VertexStream )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also