VertexStreamPosition Class


Vertex Stream Position Class

A stream that can be used to write vertices of type VertexPosition into a buffer (see VertexBuffer ).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class VertexStreamPosition : VertexStream

The VertexStreamPosition type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method AddVertex Inserts a VertexStreamPosition into the stream and associated buffer.
Public method AddVertices
Top
See Also