Vertex |
A stream that can be used to write vertices of type VertexPosition into a buffer (see VertexBuffer ).

System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The VertexStreamPosition type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from VertexStream ) |

Name | Description | |
---|---|---|
![]() | AddVertex | Inserts a VertexStreamPosition into the stream and associated buffer. |
![]() | AddVertices | Inserts multiple VertexStreamPosition instances into the stream and associated buffer. |
![]() | Dispose | (Inherited from VertexStream ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |