Hermite |
This class indicates tangency at the start, the end, or both ends of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The HermiteSplineTangents type exposes the following members.

Name | Description | |
---|---|---|
![]() | HermiteSplineTangents | Constructs a new default instance of the class, with tangent vectors uninitialized. |

Name | Description | |
---|---|---|
![]() | EndTangent | The tangent vector at the end of the curve. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | StartTangent | The tangent vector at the start of the curve. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the HermiteSplineTangents |

Initially, the tangent vectors will not be set, and no tangency condition will be imposed when the curve is created.