HermiteSplineTangents Class


Hermite Spline Tangents Class

This class indicates tangency at the start, the end, or both ends of the curve.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB HermiteSplineTangents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HermiteSplineTangents : IDisposable

The HermiteSplineTangents type exposes the following members.

Constructors
Name Description
Public method HermiteSplineTangents Constructs a new default instance of the class, with tangent vectors uninitialized.
Top
Properties
Name Description
Public property EndTangent The tangent vector at the end of the curve.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StartTangent The tangent vector at the start of the curve.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the HermiteSplineTangents
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Initially, the tangent vectors will not be set, and no tangency condition will be imposed when the curve is created.
See Also